Issues with My Work - missing items
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 11:10 UTC
Investigating
At the moment, we're investigating reports of missing data in My Work. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Sep 13, 2023 - 09:02 UTC
This incident affected: US (Other Functionalities).