Platform loading issues

Incident Report for monday.com

Resolved

The platform is now back to regular service. Please refresh your browser to access the platform. Thank you for your patience!
Posted Apr 20, 2026 - 08:53 UTC

Investigating

We have detected a loading issue with the platform; our team is aware of the issue and is actively working to bring it back to normal. We will continue to provide updates on their progress
Posted Apr 20, 2026 - 08:46 UTC
This incident affected: US (Platform) and EU (Platform).