Issues with our Forms feature - Investigating

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted 2 years ago. Mar 21, 2023 - 11:57 UTC

Investigating

At the moment, we're experiencing issues related to our Form feature. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted 2 years ago. Mar 21, 2023 - 11:31 UTC
This incident affected: US (Other Functionalities) and EU (Other Functionalities).