Connectivity Issues across accounts and devices identified
Incident Report for monday.com
Postmortem

To our monday community, we’d like to share an update about a brief service interruption that occurred on our US servers on Wednesday, July 10th, 2024.

What Happened:

  • At 8:19 PM EST, an issue with a third-party provider caused a service interruption on our US servers for approximately 35 minutes.
  • Some customers may have experienced slowness on the platform leading up to the interruption.
  • There was no data loss or security risk, and our EMEA and APAC servers were not impacted.

Our Response:

  • Our monitoring system immediately alerted our R&D teams.
  • We took steps to minimize the impact of this third-party issue by switching to another server as per our failover mechanism.
  • By 8:54 PM EST the service was restored and the platform was up and running. By 9:13 PM EST all features of the platform were fully functioning as expected, including automations & our API.
  • Our teams continued to actively monitor performance as a precaution.

What We're Doing to Prevent Similar Issues:

  • Our team is working closely with the third-party provider to investigate the root cause of the issue and improve our review processes.

We sincerely apologize for any inconvenience this interruption caused. Our top priority is to ensure a stable and reliable experience on our platform.

Additional Resources:

  • Status Page for real-time updates.
  • Contact our support team via the Help Center, we’d be happy to assist you further.
Posted Jul 11, 2024 - 10:53 UTC

Resolved
This incident has been resolved.
Posted Jul 11, 2024 - 01:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2024 - 01:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 11, 2024 - 00:54 UTC
Update
We are continuing to investigate this issue.
Posted Jul 11, 2024 - 00:44 UTC
Update
We are continuing to investigate this issue.
Posted Jul 11, 2024 - 00:42 UTC
Investigating
Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress
Posted Jul 11, 2024 - 00:30 UTC
This incident affected: US (Platform) and AUS (Platform).