Issues with Notifications
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 08:21 UTC
Investigating
At the moment, we're experiencing issues related to our notifications services. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Mar 13, 2023 - 08:07 UTC
This incident affected: US (Notifications).