Investigating issues with Processing Payment

Incident Report for monday.com

Resolved

The issue with payments has been successfully resolved.
Posted Nov 18, 2025 - 17:06 UTC

Investigating

We are currently investigating reports of payment-related issues. Our team is looking into this and will provide you with a response shortly.
Posted Nov 18, 2025 - 12:57 UTC
This incident affected: AUS (Billing), US (Billing), and EU (Billing).