Issues with our Upgrades Page

Incident Report for monday.com

Resolved

Great news! We're back to normal with our Upgrades Page, thank you for remaining patient!
Posted Aug 01, 2020 - 10:17 UTC

Investigating

We are currently experiencing issues with our Upgrades Page, our developers are on the case! Please follow this incident for further updates! We appreciate your patience in the meantime!
Posted Aug 01, 2020 - 09:25 UTC