Investigating reports of issues with our automations

Incident Report for monday.com

Resolved

The issue with our automations has been successfully resolved. Please refresh your browser to resume regular service usage. Thank you for your patience
Posted 13 days ago. Jun 09, 2025 - 09:07 UTC

Investigating

We are currently investigating reports of issues related to our automations. Our team is looking into this and will provide you with a response shortly.
Posted 13 days ago. Jun 09, 2025 - 08:52 UTC
This incident affected: US (Automations), EU (Automations), and AUS (Automations).