Issues with our WorkForms in EU server - Identified
Incident Report for monday.com
Resolved
This issue with WorkForms should be resolved now. Please refresh your browser, you should be able to return to your regular use of the services from there.
Posted Oct 25, 2023 - 08:30 UTC
Identified
Our team has identified an issue with WorkForms and is now working on re-establishing consistent support for your forms. We promise to keep you updated, as the work they're doing progresses.
Posted Oct 25, 2023 - 08:15 UTC
This incident affected: EU (Other Functionalities).