Identified the issue with our homepage
Incident Report for monday.com
Resolved
This issue with our homepage should be resolved now. Please refresh your browser, you should be able to access the site from there.
Posted Feb 24, 2021 - 08:21 UTC
Identified
Our R&D team has identified the issue and is now working on bringing our homepage back up. We promise to keep you updated, as the work they're doing progresses.
Posted Feb 24, 2021 - 08:12 UTC
This incident affected: Homepage.