Issue impacting monday notifications and emails

Incident Report for monday.com

Resolved

The issue impacting monday.com notifications and emails has been successfully resolved. Thank you for your patience.
Posted 30 days ago. Apr 02, 2025 - 19:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 30 days ago. Apr 02, 2025 - 18:49 UTC

Update

We are continuing to work on a fix for this issue.
Posted 30 days ago. Apr 02, 2025 - 18:18 UTC

Identified

Our team has identified an issue impacting monday.com notifications and emails. We will continue to provide updates on their progress.
Posted 30 days ago. Apr 02, 2025 - 18:12 UTC
This incident affected: AUS (Other Functionalities), US (Other Functionalities), and EU (Other Functionalities).