Investigating Issues with our public apps marketplace
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 15:56 UTC
Investigating
At the moment, we're experiencing issues related to our public apps marketplace. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Mar 16, 2021 - 15:37 UTC