Investigating reports of connectivity issues across accounts
Incident Report for monday.com
Postmortem

On Thursday, April 11th, at 03:18 AM EST, we experienced a service interruption on our US servers that lasted around 20 minutes and affected some of our customers' ability to access the platform. 

There was no data loss or security risk and our EMEA and APAC servers were not impacted by the downtime.

The root cause of this incident was a service issue in our service provider’s infrastructure and we’re working closely with them to investigate further. 

Our monitoring system alerted our R&D teams to the issue, and we subsequently began moving the system to a backup infrastructure. We encountered some technical difficulties in doing so, which resulted in degraded performance for 39 more minutes. API, automation, and integration services were not available globally during this time. 

In order to enable full restoration, the team opted to put the platform into read-only mode while we restored full access and functionality.

At 04:40 AM EST, the platform was fully restored and behaving as expected, and our customers were able to fully access it with no further performance issues. Our teams continued to actively monitor the platform, as per best practice.  

We deeply apologize for any inconvenience caused by this service interruption. It remains our utmost priority to provide a stable, exceptional experience on our platform and to take great care in maintaining your trust in us. 

As part of this commitment, we’re working on the ability to switch to backup servers more quickly, as well as improving our safety nets to detect potential third-party issues at an earlier stage to prevent disruption. In addition, we’re reviewing our communication processes to make sure we can proactively give you the information you need to best support your teams during maintenance or disruption. 

Our status page is accessible here. If you need account support, you can reach us via the help center, our dedicated customer experience teams will be more than happy to help you.

Posted Apr 12, 2024 - 14:28 UTC

Resolved
The platform is now back to regular service. Please refresh your browser to access the platform. Thank you for your patience
Posted Apr 11, 2024 - 09:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2024 - 08:52 UTC
Update
Our R&D teams are fully focused on resolving this incident and restoring the platform's stability. In the meantime, the platform is available on read mode only in our US server. The platform is working normally for accounts in our EU and AUS server.

We will keep you updated as we make progress on fully resolving this issue.
Posted Apr 11, 2024 - 08:41 UTC
Update
We are currently investigating reports of connectivity issues across the platform. Our team is working to resolve this promptly.
Posted Apr 11, 2024 - 07:35 UTC
Investigating
We are currently investigating reports of connectivity issues across the platform. Our team is looking into this and will provide you with a response shortly.
Posted Apr 11, 2024 - 07:25 UTC
This incident affected: US (Platform).