Connectivity Issues across accounts and devices
Incident Report for monday.com
Postmortem

On Friday, February 16th, 7:43 pm EST, we experienced around 20 minutes of service interruption on our US servers, impacting some of our customers' ability to access the platform. Our teams worked quickly to restart the platform manually, and the incident ended at 8:03 pm EST.

There was no data loss or security risk and our EMEA and APAC servers were not impacted.

The incident was caused by a recurring issue from a third-party provider and our R&D teams worked closely with the provider to identify the root cause and ensure a permanent solution.

Once a fix was identified, we scheduled a 15-minute maintenance slot at a low-traffic time to deploy the fix, and we’re glad to share that the fix was implemented successfully yesterday, February 18th, at 1:15 pm EST.

The platform is now behaving as expected and our teams will continue to actively monitor the platform, as per best practice.  

We apologize for any inconvenience and disruption during this interruption to the service. It remains our utmost priority to provide a stable, exceptional experience on our platform and to take great care in maintaining your trust in us.

Our status page is accessible here and if you need any account support, you can reach us via the help center, our dedicated customer experience teams will be more than happy to help you.

Posted Feb 19, 2024 - 17:08 UTC

Resolved
This incident has been resolved.
Posted Feb 17, 2024 - 01:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2024 - 00:48 UTC
Investigating
Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress
Posted Feb 17, 2024 - 00:43 UTC
This incident affected: US (Platform) and EU (Platform).