Identified Issue intermittently affecting File upload, download, and preview
Incident Report for monday.com
Resolved
This issue with files should be resolved now. Please refresh your browser, you should be able to return to your regular use of the services from there.
Posted Oct 09, 2021 - 01:10 UTC
Monitoring
A fix has been deployed. Please refresh your browser in order to continue to work with files without disruption.
Posted Oct 08, 2021 - 20:25 UTC
Identified
We have identified an issue with one of our infrastructure providers. Our developers are working to re-establish stable usage of file upload, download, and preview on the platform.
Posted Oct 08, 2021 - 20:15 UTC
This incident affected: US (Platform).