Identified the issue affecting our automations, integrations, and API

Incident Report for monday.com

Resolved

The issue has been successfully resolved. Please refresh your browser to resume regular service usage. Thank you for your patience
Posted Jun 09, 2025 - 11:57 UTC

Monitoring

A fix has been implemented and we are monitoring results to ensure full stability.
Posted Jun 09, 2025 - 11:48 UTC

Identified

Our team has identified the root cause of the issue affecting automations, integrations, and API, and is working to resume regular service usage. We will continue to provide updates on their progress
Posted Jun 09, 2025 - 11:44 UTC
This incident affected: US (Automations, Integrations, API, Apps), EU (Automations, Integrations, API, Apps), and AUS (Automations, Integrations, API, Apps).