Pricing page showing blank

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 11:50 UTC

Identified

We are currently investigating an issue where the Pricing Page shows a blank page when trying to pay for a plan from the trial-expired page.
In the meantime, as a workaround, please go to "Invoice details" and enter your address.
Posted Jun 24, 2026 - 07:43 UTC
This incident affected: EU (Billing).