Connectivity Issues across accounts and devices

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted 2 years ago. Jun 11, 2023 - 13:56 UTC

Investigating

At the moment, we're experiencing connectivity issues for some accounts across all devices. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted 2 years ago. Jun 11, 2023 - 13:46 UTC
This incident affected: US (Platform) and EU (Platform).