Issues with delays in emails logging in CRM and Service.

Incident Report for monday.com

Postmortem

What Happened:

On March 26th, 2025, 14:48 UTC, our US customers experienced a 9 hour and 14 minute incident. Our Simple Queue Service (SQS) began accumulating messages due to architectural issues, which resulted in slower processing of emails, hence delays in emails logging within the Emails & Activities framework.

What caused it:

There were a few accounts that received a massive number of emails which took over the entire processing. 

How we responded:

We have an additional queue on production to which we routed the problematic accounts, alleviating traffic from the main queue. 

What we're doing to prevent recurrence:

We have implemented metrics as alerts to trigger PagerDuty notifications early and are planning to update the architecture soon.

We sincerely apologize for any disruption this caused to your workflow.

Thank you for your understanding as we work to continuously improve our platform's reliability.

Your team at monday.com

Posted 11 days ago. Mar 26, 2025 - 22:34 UTC

Resolved

The email delay in Emails and Activities has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted 12 days ago. Mar 26, 2025 - 00:02 UTC

Update

We are continuing to monitor for any further issues.
Posted 12 days ago. Mar 25, 2025 - 19:29 UTC

Update

We are continuing to monitor for any further issues.
Posted 12 days ago. Mar 25, 2025 - 18:22 UTC

Monitoring

A fix has been implemented and we are monitoring results to ensure full stability with E&A!
Posted 12 days ago. Mar 25, 2025 - 17:43 UTC

Identified

Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress.
Posted 12 days ago. Mar 25, 2025 - 14:57 UTC

Investigating

We are currently investigating reports of email delays for Emails and Activities. In monday Service, there is a delay in new tickets logging and in CRM there is a delay in email logging on the E&A timeline as well as item creation. Our team is looking into this and will provide you with a response shortly.
Posted 12 days ago. Mar 25, 2025 - 14:48 UTC
This incident affected: US (Emails & Activities) and EU (Emails & Activities).