Connectivity Issues across accounts and devices - Monitoring
Incident Report for monday.com
Postmortem

Yesterday we experienced connectivity issues, which affected our users’ ability to access the platform.

The incident started at 14:20 UTC and was caused due to a specific edge case that triggered a lock in the database, which caused the downtime on our US server for a total time of 19 min.

Our developers immediately worked to resolve the underlying cause, and a fix was applied. The platform went back up at 14:39 UTC, and the issue was fully resolved. All aspects of the platform are now behaving as expected.

We sincerely apologize for the inconvenience and any frustration arising from this disturbance. We’ve since identified and resolved the root cause of the issue, adding additional protective mechanisms to prevent this specific instance. We remain focused on investing all needed resources to ensure the platform’s continued stability.

If you have any additional questions please reach out to our dedicated Customer Experience team at support@monday.com - we’re here to help.

Posted Apr 20, 2022 - 14:17 UTC

Resolved
This incident has been resolved.
Posted Apr 19, 2022 - 14:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2022 - 14:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 19, 2022 - 14:31 UTC
Investigating
We are currently investigating this issue.
Posted Apr 19, 2022 - 14:21 UTC
Monitoring
We're already seeing improvements as our team works to resolve the connectivity issues. We hope to have good news for you very shortly!
Posted Apr 19, 2022 - 14:20 UTC
This incident affected: US (Platform).