Connectivity Issues across accounts and devices
Incident Report for monday.com
Postmortem

On Monday, April 25th, a portion of customers experienced issues while loading boards, items, and in a few additional areas of the platform. The incident started at 2:30 a.m. EST and was caused due to a version update we implemented to our server environment. While the affected customers did not experience a comprehensive outage during this period, there were delays and connectivity issues which are far from the level of functionality and user experience we strive to provide. 

Our dedicated R&D task force immediately worked to identify the cause of this incident, which they understood to be a technical issue in the update itself. The incident was resolved at 4:10 a.m. EST. At 2:50 a.m. EST, April 26th, we rolled back the version update and are currently running on the previous, stable version. 

We sincerely apologize for the inconvenience you may have experienced. We understand that many of our customers rely on monday.com for their core business processes and we are committed to providing each of our customers with an exceptional and reliable experience.

If you have any additional questions please reach out to our dedicated Customer Experience team at support@monday.com.

Posted Apr 27, 2022 - 06:50 UTC

Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 08:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2022 - 08:35 UTC
Update
We are continuing to investigate this issue.
Posted Apr 25, 2022 - 08:26 UTC
Update
We are continuing to investigate this issue.
Posted Apr 25, 2022 - 08:18 UTC
Investigating
We are currently investigating this issue.
Posted Apr 25, 2022 - 08:12 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 25, 2022 - 07:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 25, 2022 - 07:11 UTC
Investigating
At the moment, we're experiencing connectivity issues for some accounts across all devices. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Apr 25, 2022 - 06:59 UTC
This incident affected: US (Platform, Login / SSO, Notifications, Search, Automations, Integrations, API).