Issues with platform not loading

Incident Report for monday.com

Postmortem

🛠️ US Region Service Disruption – July 9th, 2025

On July 9th, we experienced an unexpected service disruption in our US region, which led to temporary downtime of the platform and subsequent performance degradation in key features, including Apps, API access, and automations.

What Happened

A failure with a critical third-party service provider introduced instability across one of our tier 1 services, leading to widespread outage in key features.

How We Responded

Upon identifying the issue, our engineering teams acted swiftly to investigate the root cause and mitigate the disruption. We immediately replaced the affected instance with a healthy one and scaled up our systems to ensure the platform's stability. We were able to restore full functionality gradually, and within 50 minutes, the platform was fully operational.

We continuously monitored the system during the recovery process to ensure that there were no further interruptions. We also deployed additional resources to handle any spikes in demand during the restoration period.

What We’re Doing to Prevent It

We’re implementing additional safeguards to detect anomalies earlier, improve system scalability, strengthen internal processes to prevent similar incidents in the future, and reduce dependency in the specific instance.

Feature Downtime Summary (US Region)

Full Downtime - 13:38-14:28 (~50m)

Apps - 14:28–15:00 (~32m)

Automations delay - 14:28–15:10 (~42m)

While the disruption lasted for an extended period, no data loss occurred during the incident, and we were able to ensure the integrity of your information.

We sincerely apologize for the inconvenience and appreciate your continued trust. Please reach out if you have any questions.

The monday.com team

Posted Jul 09, 2025 - 20:06 UTC

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 13:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 13:39 UTC

Update

We are continuing to work on a fix for this issue related to the platform issues with boards and dashboards not loading or loading slowly.
Posted Jul 09, 2025 - 12:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 09, 2025 - 12:56 UTC

Investigating

We are currently investigating reports of issues related to the platform not loading or loading slowly. Our team is looking into this and will provide you with a response shortly.
Posted Jul 09, 2025 - 12:44 UTC
This incident affected: US (Platform).