Identified the Issue affecting our Dashboards feature
Incident Report for monday.com
Resolved
The issue we were experiencing with our Dashboards feature has been resolved. Please refresh your browser to return to stable usage of this aspect of the platform. If you happen to experience any further unexpected behaviour, please reach out to us at support@monday.com!
Posted Nov 13, 2019 - 09:17 UTC
Identified
We have identified the cause of the issue with our Dashboards feature and our developers are working to re-establish stable usage of this aspect of the platform. We promise to keep you updated with their progress.
Posted Nov 13, 2019 - 09:11 UTC
This incident affected: Dashboards.