Investigating issues with Files in the Updates Section
Incident Report for monday.com
Resolved
The issue we were experiencing with our Files in the Updates Section has been resolved. Please refresh your browser to return to normal usage of this aspect of the platform.
Posted Feb 15, 2023 - 19:55 UTC
Investigating
At the moment, we're experiencing issues related to our Files in the Updates Section. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Feb 15, 2023 - 18:03 UTC
This incident affected: US (Files) and EU (Files).