Investigating issues with our career site

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted 3 years ago. Jul 29, 2022 - 07:06 UTC

Update

We are continuing to investigate this issue. At the moment, we believe it is due to a third party website's failure.
Posted 3 years ago. Jul 28, 2022 - 21:37 UTC

Investigating

At the moment, we're experiencing issues related to our careers page. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted 3 years ago. Jul 28, 2022 - 18:16 UTC
This incident affected: US (Other Functionalities) and EU (Other Functionalities).