Connectivity & Automation Issues across accounts and devices
Incident Report for monday.com
Resolved
Great news - monday.com is now fully operational, please refresh your browser and try accessing the platform. If you can't immediately connect, please clear your cache and cookies, refresh your page and try again.

Automations that were set to trigger between approximately 4pm EDT - 4:20pm EDT failed to run, and will need to be re-triggered.
Posted Jul 20, 2021 - 22:46 UTC
Monitoring
We're already seeing improvements as our team works to resolve these issues. Any subitems, boards, or dashboards that were created during this time should now be visible. Automations should now be working properly. If you continue to experience issues, please refresh your page and try again. We hope to have good news for you very shortly!
Posted Jul 20, 2021 - 22:39 UTC
Identified
Things are looking up! Our R&D team has identified the issue and is now working on restoring consistent access to your monday.com account. Any users that were previously experiencing issues with board and dashboard creation, subitem creation, or issues with uploading or downloading files should now be resolved - although we're still working on an issue with automations.
Posted Jul 20, 2021 - 22:18 UTC
Investigating
At the moment, we're experiencing connectivity issues for some accounts across all devices. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Jul 20, 2021 - 21:17 UTC
This incident affected: US (Platform, Login / SSO, Notifications, Search, Automations, Integrations, Activity Log, API).