Issues with our Checkout Page
Incident Report for monday.com
Resolved
We're good to go here, thanks for remaining patient throughout!
Posted May 30, 2020 - 19:51 UTC
Monitoring
Great news! We've just finished deploying a fix to the checkout page issue and things are looking much better! Please refresh your page to regain regular access!
Posted May 30, 2020 - 18:09 UTC
Update
We're still evaluating a fix to the checkout page issue, not allowing for users to upgrade their accounts. We apologise for the delay and appreciate your patience here!
Posted May 30, 2020 - 16:57 UTC
Identified
We're currently experiencing issues with our checkout page, users looking to upgrade won't be able to at the moment. We've identified the root cause and are working towards resolving the issue as soon as possible. Thank you for your patience.
Posted May 30, 2020 - 13:51 UTC