Docs are not loading
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted 5 months ago. Sep 25, 2024 - 06:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Sep 25, 2024 - 06:40 UTC
Identified
Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress.
Posted 5 months ago. Sep 25, 2024 - 06:22 UTC
This incident affected: US (monday workdocs).