Investigating connectivity issues across accounts and devices

Incident Report for monday.com

Resolved

The connectivity issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience!
Posted 18 days ago. May 06, 2025 - 13:30 UTC

Update

We are continuing to investigate this issue.
Posted 18 days ago. May 06, 2025 - 13:26 UTC

Investigating

We are currently investigating reports of connectivity issues across the platform. Our team is working to resolve this promptly.
Posted 18 days ago. May 06, 2025 - 13:24 UTC
This incident affected: US (Platform), EU (Platform), and AUS (Platform).