Issues affecting upgrades
Incident Report for monday.com
Resolved
We're all good here, platform upgrades are back to normal! Thanks for remaining patient!
Posted Jun 14, 2020 - 18:32 UTC
Monitoring
Things are looking up and we're monitoring a fix that we deployed! You should be able to perform upgrades on the platform after refreshing your page.
Posted Jun 14, 2020 - 18:11 UTC
Update
We're still investigating issues with the ability to process upgrades. We will continue to update as we progress.
Posted Jun 14, 2020 - 17:49 UTC
Investigating
At the moment, we're experiencing issues with the ability to process upgrades. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Jun 14, 2020 - 16:43 UTC