Investigating Issues with Purchasing and Changing Plans
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 19:28 UTC
Update
We are continuing to investigate this issue.
Posted Dec 15, 2021 - 16:36 UTC
Investigating
We're currently experiencing issues with our checkout page, users looking to purchase plan or upgrade may not be able to at the moment. We're investigating the issue as we speak and will update here as soon as possible.
Thank you for your patience.
Posted Dec 15, 2021 - 16:35 UTC