Currently facing connectivity issues across accounts and devices
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Feb 25, 2024 - 09:00 UTC
Investigating
We are currently investigating reports of connectivity issues across the platform. Our team is working to resolve this promptly.
Posted Feb 25, 2024 - 08:54 UTC
This incident affected: US (Platform), EU (Platform), and AUS (Platform).