Monitoring connectivity issues across accounts and devices

Incident Report for monday.com

Resolved

The platform is now back to regular service. Please refresh your browser to access the platform. Thank you for your patience
Posted Oct 26, 2025 - 07:09 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 26, 2025 - 07:09 UTC

Monitoring

We had connectivity issues for a few minutes in the US server. A fix has been implemented, and we are monitoring results to restore full system stability
Posted Oct 26, 2025 - 07:03 UTC
This incident affected: US (Platform).