Incident with My Work, Dashboards, and Boards
Incident Report for monday.com
Resolved
This incident has been resolved. Dashboards, board views, and My Work are fully operational.
Posted Jan 19, 2022 - 16:51 UTC
Investigating
We are currently investigating an issue with My Work, Dashboards, and Board Views showing up as blank.
Posted Jan 19, 2022 - 16:43 UTC
This incident affected: US (Platform, Dashboards, Other Functionalities) and EU (Platform, Dashboards, Other Functionalities).