Monitoring issues with board editing

Incident Report for monday.com

Resolved

The board issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted 10 months ago. May 20, 2024 - 17:47 UTC

Monitoring

A fix has been implemented and we are monitoring results to ensure full system stability.
Posted 10 months ago. May 20, 2024 - 17:08 UTC

Update

We are continuing to investigate this issue.
Posted 10 months ago. May 20, 2024 - 16:54 UTC

Investigating

We are currently investigating reports of issues related to editing boards. Our team is looking into this and will provide you with a response shortly.
Posted 10 months ago. May 20, 2024 - 16:46 UTC
This incident affected: US (Platform), EU (Platform), and AUS (Platform).