Partial UI functionality degradation

Incident Report for monday.com

Resolved

The issue affecting UI platform functionalities, including the Search functionality, has been successfully resolved. Please refresh your browser to resume regular service usage. Thank you for your patience
Posted Sep 17, 2026 - 11:05 UTC

Monitoring

A fix has been implemented to the UI Search functionality issue and we're monitoring the results.
Posted Sep 17, 2026 - 10:43 UTC

Identified

The issue has been identified, and a fix is being implemented.
Posted Sep 17, 2026 - 09:35 UTC

Update

We are continuing to investigate this issue.
Posted Sep 17, 2026 - 09:16 UTC

Investigating

We're currently investigating an issue affecting some UI platform functionalities, including the Search functionality.
Posted Sep 17, 2026 - 09:11 UTC
This incident affected: US (Search), EU (Search), IL (Search), and AUS (Search).