Investigating issues with inviting new users to the platform
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Nov 21, 2021 - 09:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2021 - 08:39 UTC
Investigating
At the moment, we're experiencing issues related to our invite users flow. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Nov 21, 2021 - 08:30 UTC
This incident affected: US (Login / SSO) and EU (Login / SSO).