Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 27 days ago. May 25, 2025 - 14:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted 30 days ago. May 22, 2025 - 15:55 UTC
Scheduled
On Sunday, May 25th at 14:00 UTC, we will be performing scheduled maintenance on our platform in the AU region. This maintenance window is expected to last up to one hour.
During this time, monday boards will intermittently be in read-only mode, where actions like creating items, editing boards, creating boards from templates, and changing board permissions will be temporarily unavailable. The API will also briefly enter read-only mode during the maintenance.
Thank you for your understanding during this planned maintenance.
Posted 1 month ago. May 20, 2025 - 20:35 UTC
This scheduled maintenance affected: AUS (Platform, API).