Investigating reports of issues with our forms

Incident Report for monday.com

Resolved

The issue with our forms has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience!
Posted Feb 05, 2025 - 09:45 UTC

Monitoring

A fix has been implemented and we are monitoring results to ensure full system stability.
Posted Feb 05, 2025 - 09:41 UTC

Update

Our team has identified the root cause of the issue with WorkForms. We have a degraded performance for a few accounts and we are actively working on a fix.

We appreciate your patience.
Posted Feb 05, 2025 - 00:39 UTC

Identified

Our team has identified the root cause of the issue affecting WorkForms and is working to resume regular service usage. We will continue to provide updates on their progress
Posted Feb 04, 2025 - 23:57 UTC

Update

We are investigating an issue with WorkForms not loading in the US. Our team is looking into this and will provide you with a response shortly.
Posted Feb 04, 2025 - 23:06 UTC

Update

We are currently investigating reports of issues related to our forms. Our team is looking into this and will provide you with a response shortly.
Posted Feb 04, 2025 - 23:00 UTC

Update

We are continuing to investigate this issue.
Posted Feb 04, 2025 - 22:45 UTC

Investigating

We are currently investigating reports of issues related to our forms. Our team is looking into this and will provide you with a response shortly.
Posted Feb 04, 2025 - 22:11 UTC
This incident affected: US (Other Functionalities).