Identified the issue affecting our sign-up flow (editing content after initial sign up)
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Nov 28, 2021 - 13:58 UTC
Identified
Our R&D team has identified the issue and is now working on re-establishing consistent support to our sign-up flow. We promise to keep you updated, as the work they're doing progresses.
Posted Nov 28, 2021 - 12:37 UTC
This incident affected: US (Platform, Login / SSO).