Issues loading boards
Incident Report for monday.com
Resolved
Great news - monday.com is now fully operational, please refresh your browser and try accessing the platform. If you can't immediately connect, please clear your cache and cookies, refresh your page and try again.
Posted Aug 23, 2021 - 07:18 UTC
Monitoring
We're already seeing improvements as our team works to resolve the connectivity issues. We hope to have good news for you very shortly!
Posted Aug 23, 2021 - 07:11 UTC
Investigating
At the moment, we're experiencing issues with loading boards. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted Aug 23, 2021 - 07:07 UTC
This incident affected: US (Platform, Login / SSO, Notifications, Search, Automations, Integrations, Activity Log, API).