Unplanned maintenance on Inbox
Incident Report for monday.com
Resolved
This issue with our inbox should be resolved now. Please refresh your browser, you should be able to return to your regular use of the services from there.
Posted Nov 01, 2022 - 07:35 UTC
Update
The inbox is under maintenance. The estimated time of resolution is 8:00 AM EST (subject to change).
Posted Oct 31, 2022 - 23:43 UTC
Identified
Unplanned maintenance on inbox and search function (all search functions affected currently)
Posted Oct 31, 2022 - 20:03 UTC
This incident affected: US (Platform, Search, Other Functionalities).