Issues with our Updates section
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted May 31, 2023 - 14:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 31, 2023 - 13:28 UTC
Investigating
At the moment, we're experiencing issues loading the Updates section. Our development team is on the case and diligently working to resolve this matter as quickly as possible.
Posted May 31, 2023 - 13:26 UTC
This incident affected: US (Other Functionalities).