Issues with slowness within My Work and searching
Incident Report for monday.com
Resolved
This incident has been resolved.
Posted Jun 17, 2024 - 15:47 UTC
Identified
Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress.
Posted Jun 17, 2024 - 14:27 UTC
Investigating
We are currently investigating issues related to slowness within My Work and searching. Our dedicated team is working to resolve this as quickly as possible
Posted Jun 17, 2024 - 13:30 UTC
This incident affected: EU (Search, Other Functionalities).