Investigating issues with Platform Slowness
Incident Report for monday.com
Resolved
The issue with platform slowness has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted Jul 01, 2024 - 13:54 UTC
Monitoring
A fix has been implemented and we are monitoring results to ensure full system stability.
Posted Jul 01, 2024 - 13:26 UTC
Investigating
We are currently investigating reports of issues related to platform slowness. Our team is looking into this and will provide you with a response shortly.
Posted Jul 01, 2024 - 13:18 UTC
This incident affected: US (Platform).