Investigating issues with API Latency

Incident Report for monday.com

Resolved

This incident has been resolved.
Posted 2 months ago. Feb 18, 2025 - 10:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Feb 18, 2025 - 10:28 UTC

Investigating

We are currently experiencing issues related to latency with the API. Our dedicated team is working to resolve this as quickly as possible.
Posted 2 months ago. Feb 18, 2025 - 10:15 UTC
This incident affected: EU (API).