monday.com

All Systems Operational

About This Site

Welcome to monday.com's status page where you can follow the operational status of our platform as well as other key features and services. We'll communicate any interruptions we encounter on this page.

US Operational
90 days ago
99.99 % uptime
Today
Platform Operational
90 days ago
99.98 % uptime
Today
Dashboards Operational
90 days ago
100.0 % uptime
Today
Login / SSO Operational
90 days ago
100.0 % uptime
Today
Notifications Operational
90 days ago
100.0 % uptime
Today
Search Operational
90 days ago
100.0 % uptime
Today
Automations Operational
90 days ago
99.97 % uptime
Today
Integrations Operational
90 days ago
99.97 % uptime
Today
API Operational
90 days ago
99.97 % uptime
Today
Communication Operational
90 days ago
100.0 % uptime
Today
Apps Operational
90 days ago
99.98 % uptime
Today
monday workdocs Operational
90 days ago
100.0 % uptime
Today
Files Operational
90 days ago
100.0 % uptime
Today
Billing Operational
90 days ago
100.0 % uptime
Today
Other Functionalities Operational
90 days ago
100.0 % uptime
Today
Support Operational
90 days ago
100.0 % uptime
Today
Emails & Activities Operational
90 days ago
100.0 % uptime
Today
EU Operational
90 days ago
99.98 % uptime
Today
Platform Operational
90 days ago
99.95 % uptime
Today
Dashboards Operational
90 days ago
100.0 % uptime
Today
Login / SSO Operational
90 days ago
100.0 % uptime
Today
Search Operational
90 days ago
100.0 % uptime
Today
Automations Operational
90 days ago
99.95 % uptime
Today
Integrations Operational
90 days ago
99.93 % uptime
Today
API Operational
90 days ago
99.96 % uptime
Today
Communication Operational
90 days ago
99.99 % uptime
Today
Apps Operational
90 days ago
99.98 % uptime
Today
monday workdocs Operational
90 days ago
100.0 % uptime
Today
Files Operational
90 days ago
100.0 % uptime
Today
Billing Operational
90 days ago
100.0 % uptime
Today
Other Functionalities Operational
90 days ago
100.0 % uptime
Today
Notifications Operational
90 days ago
99.97 % uptime
Today
Support Operational
90 days ago
100.0 % uptime
Today
Emails & Activities Operational
90 days ago
100.0 % uptime
Today
AUS Operational
90 days ago
99.99 % uptime
Today
Platform Operational
90 days ago
99.99 % uptime
Today
Dashboards Operational
90 days ago
100.0 % uptime
Today
Login / SSO Operational
90 days ago
100.0 % uptime
Today
Notifications Operational
90 days ago
100.0 % uptime
Today
Search Operational
90 days ago
100.0 % uptime
Today
Automations Operational
90 days ago
99.97 % uptime
Today
Integrations Operational
90 days ago
99.97 % uptime
Today
API Operational
90 days ago
99.97 % uptime
Today
Communication Operational
90 days ago
100.0 % uptime
Today
Apps Operational
90 days ago
99.98 % uptime
Today
monday workdocs Operational
90 days ago
100.0 % uptime
Today
Files Operational
90 days ago
100.0 % uptime
Today
Billing Operational
90 days ago
100.0 % uptime
Today
Other Functionalities Operational
90 days ago
100.0 % uptime
Today
Support Operational
90 days ago
100.0 % uptime
Today
Emails & Activities Operational
90 days ago
100.0 % uptime
Today
Datadog US1 APM Operational
Datadog US1 APM Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Jun 20, 2025

No incidents reported today.

Jun 19, 2025

No incidents reported.

Jun 18, 2025

No incidents reported.

Jun 17, 2025

No incidents reported.

Jun 16, 2025
Resolved - The apps Marketplace loading issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Jun 16, 15:40 UTC
Update - We are continuing to monitor for any further issues.
Jun 16, 15:22 UTC
Monitoring - We had an issue with Apps Marketplace loading in all regions. Our team has released a fix for it and now are currently monitoring.
Jun 16, 15:12 UTC
Resolved - This incident has been resolved.
Jun 16, 11:22 UTC
Monitoring - A fix has been implemented and we are monitoring the results.
Jun 16, 10:51 UTC
Investigating - We are currently experiencing issues related to Degraded Performance. Our dedicated team is working to resolve this as quickly as possible
Jun 16, 10:42 UTC
Jun 15, 2025

No incidents reported.

Jun 14, 2025

No incidents reported.

Jun 13, 2025

No incidents reported.

Jun 12, 2025
Resolved - This incident has been resolved.
Jun 12, 20:41 UTC
Investigating - We are currently experiencing latency issues related to the CRM and Monday Service. Our dedicated team is working to resolve this as quickly as possible
Jun 12, 17:30 UTC
Postmortem - Read details
Jun 17, 18:14 UTC
Resolved - The platform is now back to regular service. Please refresh your browser to access the platform. Thank you for your patience
Jun 12, 15:09 UTC
Monitoring - A fix has been implemented, and we are monitoring results to restore full system stability
Jun 12, 14:55 UTC
Update - Notifications should be working as expected now. Automations and integrations may still be delayed. We are continuing to work to fully resolve the issue
Jun 12, 14:52 UTC
Update - Automations and integrations are up but may be delayed. We're still working to solve the issue with notifications. We appreciate your patience
Jun 12, 14:38 UTC
Update - API should be working as expected now. We are continuing to work on a fix for the issues with automations, integrations, and notifications
Jun 12, 14:07 UTC
Update - Automations, API, and notifications are still not working as expected. We're working to resolve the issues and will continue to provide updates on our progress
Jun 12, 13:47 UTC
Update - The platform should be working mostly as expected. Our team is still working on issues with automations and notifications
Jun 12, 13:28 UTC
Identified - Our team has identified the root cause of the issue and is working to resume regular service usage. We will continue to provide updates on their progress
Jun 12, 13:20 UTC
Investigating - We are currently investigating reports of connectivity issues across the platform. Our team is working to resolve this promptly.
Jun 12, 12:31 UTC
Jun 11, 2025

No incidents reported.

Jun 10, 2025

No incidents reported.

Jun 9, 2025
Resolved - The issue has been successfully resolved. Please refresh your browser to resume regular service usage. Thank you for your patience
Jun 9, 11:57 UTC
Monitoring - A fix has been implemented and we are monitoring results to ensure full stability.
Jun 9, 11:48 UTC
Identified - Our team has identified the root cause of the issue affecting automations, integrations, and API, and is working to resume regular service usage. We will continue to provide updates on their progress
Jun 9, 11:44 UTC
Resolved - The issue with our automations has been successfully resolved. Please refresh your browser to resume regular service usage. Thank you for your patience
Jun 9, 09:07 UTC
Investigating - We are currently investigating reports of issues related to our automations. Our team is looking into this and will provide you with a response shortly.
Jun 9, 08:52 UTC
Jun 8, 2025
Completed - The scheduled maintenance has been completed.
Jun 8, 09:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Jun 8, 07:00 UTC
Scheduled - On Sunday, June 8th at 07:00 UTC, we will be performing scheduled maintenance on our apps across all servers. This maintenance window is expected to last up to two hours.

During this time, apps within the monday App marketplace may experience degraded performance, with app actions being intermittently unavailable.

For any questions during the maintenance period, please reach out to the app developer directly by navigating to the Apps Marketplace under your profile, selecting your app, and clicking “Contact Developer.”

Thank you for your understanding during this scheduled maintenance.

Jun 3, 16:49 UTC
Jun 7, 2025
Completed - The scheduled maintenance has been completed.
Jun 7, 07:30 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Jun 7, 06:30 UTC
Scheduled - On Saturday, June 7th, at 06:30 UTC, we will be performing scheduled maintenance on our platform in the EU region. This maintenance window is expected to last up to one hour.

During this time, monday boards will intermittently be in read-only mode, where actions like creating items, editing boards, creating boards from templates, and changing board permissions will be temporarily unavailable. The API will also briefly enter read-only mode during the maintenance.

Thank you for your understanding during this planned maintenance.

Jun 2, 21:15 UTC
Jun 6, 2025

No incidents reported.